Default stop_finder query returns empty locations array


#1

Hi,

I am trying to use the stop_finder endpoint with the default query params but am receiving an empty array for locations.

I have tried different values for the name_sf but it yields the same result.

Other endpoints seem to be working as expected.

Here is the query:
https://api.transport.nsw.gov.au/v1/tp/stop_finder?outputFormat=rapidJSON&name_sf=Circular%20Quay&coordOutputFormat=EPSG%3A4326&TfNSWSF=true&version=10.2.1.42
Authorization: apikey xxxx

And here is the response:
GET https://api.transport.nsw.gov.au/v1/tp/stop_finder?outputFormat=rapidJSON&name_sf=Circular+Quay&coordOutputFormat=EPSG%3A4326&TfNSWSF=true&version=10.2.1.42

HTTP/1.1 200 OK
Date: Thu, 15 Nov 2018 22:51:28 GMT
Content-Type: application/json
Connection: keep-alive
Set-Cookie: AWSALB=H0HAFHlLvYM4apyTqk2hqa7ysnfgUE44EOvPC6SxAY+eXxGXPZm9K5vl3f4nDKs/vRO3UMTRGEl4rsUId4kJGHxZBcrnsZx1E13dXubkYWUwPqGo9QE0l5JRZmvD; Expires=Thu, 22 Nov 2018 22:51:28 GMT; Path=/
Server: Apache-Coyote/1.1
Accept: application/json
Accept-Ranges: none
X-Frame-Options: SAMEORIGIN
X-Cache: Miss from cloudfront
Via: 1.1 eda9fe2763cea4a982a09ceb352512a6.cloudfront.net (CloudFront)
X-Amz-Cf-Id: jvRZRRYLKTij-ffzJyUPQ8nA34Nr9IPC2N7gA5PD2O_i0ly9-LhPLQ==

{
“version”: “10.2.1.42”,
“locations”:
}

Response code: 200 (OK); Time: 275ms; Content length: 38 bytes

Any ideas?


#2

Hi @cmgcode, I’m getting a response when setting the type_sf parameter to ‘any’.

Thanks,
Alex


#3

That was it!

The default value is empty when running the query through the API explorer.

Thanks for that!