Can't get an API key

Can anyone help please?

I have registered for access to opendata and have been trying to get an API key so that I can access the marine datasets Search | TfNSW Open Data Hub and Developer Portal
for viewing in QGIS and use to develop an offline nautical chart product.

However I have been unable to get an API key through the “Create Application” page. When I click the ADD ITEMS button in the API Management section.I get an error message: An AJAX HTTP error occurred. HTTP result code:504"

So I tried to email ithelp@transport.nsw.gov.au and the email bounced with the message

SY4AUS01FT007.mail.protection.outlook.com rejected your message to the following email addresses:

001_TNSW_ithelp@transportcloud.mail.onmicrosoft.com
A communication failure occurred during the delivery of this message. Please try resending the message later. If the problem continues, contact your helpdesk.

SY4AUS01FT007.mail.protection.outlook.com gave this error:
Recipient address rejected: Access denied. AS(201806281) [SY4AUS01FT007.eop-AUS01.prod.protection.outlook.com]

So I tried the opendata@transport.nsw.gov.au - rejected with same message!

Am I doing something wrong or is there something wrong?

1 Like

Hi,

Thanks for reporting this issue, we are looking into it.

Are you able to send us an email and we will be able to help. You can find our email in the Contact Us section at the bottom of the homepage, in ‘General Enquiry’ link, or you can click on it and it should open using your default mail app.

Hello, I am also facing the same issue while trying to create a new application. The gateway times out while trying to select a list of available APIs.

hi @bhalicki - thanks for posting this. We are continuing to look into this issue.

In the meantime we’ll reach out to you directly to see if we can have a look and update this for you.

© Transport for NSW