All GTFS for Real-Time Fails Download


#1

I have been able to get an access token and add it as an Authorization header, but all download attempts still fail.

Download failed: https://api.transport.nsw.gov.au:8443/v1/gtfs/schedule/ferries - 500 Connect failed: connect: Unknown error; Unknown error

This is the result for all the GTFS for real-time filesets, except lightrail which is 404.


#2

I don’t even see the 500 error, it just times out. If I drop the port number to have it fall back to just 443, then the request completes quickly but the response is an error:

$ curl -H 'Authorization: "Bearer <redacted>"' 'https://api.transport.nsw.gov.au/v1/gtfs/vehiclepos/buses'
{ "ErrorDetails":{ "TransactionId":"00000154124f347b-3111", "ErrorDateTime":"2016-04-19T20:29:14.447+10:00", "Message":"The calling application is unauthenticated.", "RequestedUrl":"/v1/gtfs/vehiclepos/buses", "RequestMethod":"GET" } }

This is my first time attempting to access the API so I’m not confident that this request has ever worked before (though I’m sure it conforms to the docs). I tried a few permutations of the Authorization header too, e.g. Authorization: Bearer xx-yy-zz, Authorization: "Bearer xx-yy-zz", Authorization:"Bearer xx-yy-zz".


#3

Ahh I’ve got it to work now. The tricks I needed to perform:

  1. Drop the port :8443 from the URL (unlike the reference specifies)
  2. Ensure your application’s auth settings have a URL defined, and scope set to ‘user’ (this should be reflected in the authorization response, it should say ‘scope: user’)
  3. Format the header like so: Authorization: Bearer xxx-yyy-zzz (no quotes, unlike the docs specify)

#4

I changed

“&”
to
“&”
as the var delimiter in the post data for the access token and it worked.

:slight_smile: