Teething issues


#1

Hi guys

We know it’s been exciting but also a bit frustrating with the Open Data Program… The platform is going through a few teething issues. We’re working hard in the background to harden the infrastructure and appreciate your patience. Do keep an eye on the status page (which at times can look like it’s not working but it is… just takes a bit of time to load!) as we also add commentary up the top of the page to keep you up to date.

The API Gateway has had a few issues in the last few days - I like to think of it because all of you are so eagar in accessing!

We’ll be keeping a keen eye on things over the long weekend where I’m sure you guys (and gals!) will be coding and inspecting the data.

Regards
Yvonne and the Open Data team


#2

So, not sure if you guys are aware… but it looks like the GTFS-R vehicle position data for Sydney Trains is currently truncated. Only returning ~3KB of data.

ping @yvonne.lee


#3

thanks. Sorry wasn’t keeping an eye on things. It could be related to the other issues. I did see your site had no trains, should have realised!

We’re looking into it now.


#4

OK so we’re doing a fix tonight to the API gateway - should be between 6pm and 9pm tonight but it shouldn’t really affect you - at most it will just be a disruption for a couple of your API calls.

We believe it will fix the truncation issues (both scheduled and real time data).

EDIT - change now happening between midnight and 2am. Status page has been updated to reflect this.


#5

Solid! We’re back up and running again, and static data is looking good too :smiley:

Archive:  gtfs.zip
  Length      Date    Time    Name
---------  ---------- -----   ----
  5097401  04-22-2016 01:45   trips.txt
     7881  04-22-2016 01:45   calendar.txt
 82173869  04-22-2016 01:45   stop_times.txt
   126251  04-22-2016 01:45   stops.txt
    15325  04-22-2016 01:45   routes.txt
      281  04-22-2016 01:45   agency.txt
  3447569  04-22-2016 01:45   shapes.txt
---------                     -------
 90868577                     7 files

#6

Sorry. I was just about to come and update the status as it’s not happened yet. But there was a reboot of the servers at 7pm which may have assisted.

But good that things are a bit better for you.


#7

The API Gateway changes have now been made.


#8

Just on more early teething issues - when you try to use the direct download link to download an offline copy of the GTFS Static Timetable/Stop Locations/Route Shape zip file on the main dashboard, you end up with an XML file with a “Policy Falsified” error from Amazon Web Services.

The behavour doesn’t seem to be browser dependent - I’ve tried using Windows 7/Chrome and Windows 10/Edge with similar results.


#9

Ditto. Though on occasion I can’t even reach the error. Issue appears to be affecting every direct download available from the dashboard.

Here is the full error, as seen in Edge in Windows 10.

<?xml version="1.0" encoding="UTF-8"?>
- <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
    - <soapenv:Body>
	    - <soapenv:Fault>
		    <faultcode>soapenv:Server</faultcode>
		    <faultstring>Policy Falsified</faultstring>
		    <faultactor>https://tfnsw-ca-api-g-elb-zwswxfxus1f5-816410105.ap-southeast-2.elb.amazonaws.com/users/sign_in</faultactor>
		    - <detail>
			    <l7:policyResult xmlns:l7="http://www.layer7tech.com/ws/policy/fault" status="Service Not Found. The request may have been sent to an invalid URL, or intended for an unsupported operation."/>
		    </detail>
	    </soapenv:Fault>
    </soapenv:Body>
</soapenv:Envelope>

#10

Thanks guys. We’ll take a look.


#11

Just a quick update - we’re still looking into what’s happening with the direct downloads.

For now you can still get it via the API Explorer. But it does mean you need to follow the instructions and set up an app etc.


#12

Thanks for the heads up.


#13

Thanks for the update Yvonne.

I’ll wait a few days to see if it gets fixed - failing which, I’ll use the workaround and request it via the API.


#14

If you were a TDX subscriber you can still get it from TDX for now (but we’ve hidden the way to login). If you are desperate please send me a PM and I will send you the file until we get it up and running again.


#15

Took a while to find the link in my browsing history, but I found it. Thanks for letting my know it was still on the old system. And good luck finding the fix!


#16

The direct downloads from the dashboard are up and running again.

Thanks for your patience.