Filters in Trip Planner API

hello everyone,

I have been accessing trip planner API, I am not able to filter specific mode of transport for the trip planning request.

my request contains following parameters along with other parameters
exclMOT_1: ‘on’,
exclMOT_7: ‘on’,
exclMOT_5: ‘on’,
but response still contains the route options having BUS and trains.
do I missing something ?

Does it work if you use the parameter value 1 rather than on? See: Filter params departure_mon - #3 by jxeeno

if we use 1 instead of on then its giving same result. not working.

Ah, you’ll need the excludedMeans=checkbox parameter as well.

You can also do the inverse. i.e. to get train services only, includedMeans=checkbox&inclMOT_1=1

@alejandro.felman something to add to the documentation / Swagger :slight_smile:

1 Like

that’s perfect. it’s working now.thanks a lot. you should update this on your documentation. :pray::pray:

is there any other option for enable/disable of Opal enabled services only ?

there is no parameter that I found on API.

Please try lineRestriction=403