Direct Download GTFS For Greater Sydney Area Timing Out


#1

I tried a second time just now and the request times out.

https://opendata.transport.nsw.gov.au/direct/full_greater_sydney_gtfs_static.zip

It’s been timing out for a few days.

The docs suggest no authentication is needed, but it fails even with the OAuth2 header.

Is there a secret? Any ideas when to check back?


#2

This issue has also been reported here and they’re looking into it


#3

The direct downloads from the dashboard are up and running again.

Thanks for your patience.


#4

What about authentication?

I just tried direct download using browser and it started OK.

I then tried from our system with the OAuth2 header and got 401.

I then tried direct download using browser again and got:

{
“ErrorDetails”:
{
“TransactionId”:“000001543eb7b14f-5faa2”,
“ErrorDateTime”:“2016-05-04T14:13:40.633+10:00”,
“Message”:“Calling application is not authenticated”,
“RequestedUrl”:"/v1/download/tdx/full_greater_sydney_gtfs_static.zip",
“RequestedMethod”:“GET”
}
}

So, what are the authentication rules, if any, for the direct download?


#5

The idea of the direct downloads was for people who weren’t necessary wanting to use it for development purposes. ie data analysts or people who just download it every so often (and don’t want to create an app etc to get the data).

So the authentication rules for the direct download are meant to be… you login you can download them. Maybe your session had timedout?

In your case @Webmaster I would recommend you just get it as an API call.


#6

Got it working as an API call. Thank you. :slight_smile: