Authentication Via API Key


#1

Hello,

Looks like things are progressing, thank you.

I am still seeing authentication via API key failing.

This means per user per session authentication is required, which is the first of it’s kind I’ve seen (this can also cause unnecessary work for application support).

I am hoping getting all authentication methods in the API Explorer working is on your todo list.

:neutral_face:


#2

“it’s on the list” :slight_smile:

We’re trying to get more simple authentication that doesn’t timeout in place.


#3

Hello,

Any update on the status of getting authentication by API key working? :confused:


#4

Hello,

Any update on the status of getting authentication by API key working? :confused:


#5

API Key authentication is available and shouldn’t time out at all. Have a look at https://opendata.transport.nsw.gov.au/site/en_us/gs-intro.html which details OAuth and API authentication methods.

After creating an application with API Key add a Authorization header set to “apikey my_key_goes_here”.


#6

Hi @Webmaster, as @phiali said, this should work correctly. Please follow the steps in our user guide page linked above and try again. If you’re still having problems feel free to message me the command you’re using so I can review it.

Thanks,
Alex


#7

Thanks for the help.

By authentication via API Key I mean as described in the API Explorer.

Authentication by just the api_key as in:

https://api.transport.nsw.gov.au/v1/gtfs/realtime/nswtrains?apikey=mykey

I have OAuth working, but that requires a per user per session unique token, which is a framework we currently do not have implemented.

So, I am asking if there is any progress on completing support for authentication via API key as listed in the API Explorer? :confused:


#8

The API key can’t be specified in the URL so you’ll need to set it in the HTTP headers.


#9

I selected Header as the API Key Type in API Explorer and still get 401 Unauthorized

I manually added a header parameter apikey with mykey as value and type header and still got 401 Unauthorized.

:confused:


#10

Okay, I’m seeing the User Guide is updated.

I followed the instructions and instead of 401, I get redirected to the Dashboard. (Perhaps caused by a protobuf response).

I’ll take all this to mean you have it up and running now.

Thank you for the help.

:sunglasses: