Real time trip update in alteryx

Hi guys
I want to do a predictive analysis in alteryx using Public Transport - Realtime Trip Updates API. I use request URL and api key but keep getting 401 error. Calling application not authorized. Any help is welcome

I think in the Open Data hub you need to add the API to your application. If you’ve already done that, then some more details would be needed to help you.

I have done that. What details do you need? I tried putting in the request url and api key. But the error is 401 calling app not authenticated.

wait. is it not authorized, or not authenticated? those are two very different things. not authorized means your application authenticated, but isn’t allowed to access the api. not authenticated means the api key wasn’t applied properly or is invalid.

how you put the api key into alteryx would be the important bit of detail, since you’ve already added the API to your application.

The error is HTTP/1.1 401 Unauthorized
I put the api key by copying it from the curl command so it is
apikey iT9QxxxxxxxxxxxxxxxxxxxxxxxObkBMOxn

So I guess that means the application authenticated. How do I allow it to access the api.

If it’s working with curl, then it must be something specific to how alteryx is setting the header. Is there any documentation from alteryx?


here is the document I am trying to follow.

i looked at that link and found a link to https://community.alteryx.com/t5/Alteryx-Designer-Knowledge-Base/Guide-to-Creating-Your-Own-Connector-Authentication/ta-p/23582 which looks better.

The second image looks like it should work, so if you have spelled everything correctly, it really should work.
image

Is there any way in Alteryx to see all the headers (request and response)? There may be other headers in the request that are causing issues?

1 Like

I had used apikey for name. I tried it with Authorization and it works now. Thankyou very much.

1 Like
© Transport for NSW